Commit cbd6b72d authored by Sebastian Achilles's avatar Sebastian Achilles
Browse files

update to EasyBuild 4.5.4

parent c7c8806c
Pipeline #103145 failed with stages
in 2 minutes and 59 seconds
......@@ -4,7 +4,7 @@ ARG IMG_TAG=8.5
# allow CI/CD to change all of the above
FROM ${IMG_REGISTRY}/${IMG_NAME}:${IMG_TAG}
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# install required packages (EPEL is required for Lmod)
# RUN yum update -y
......
......@@ -16,7 +16,7 @@ RUN chown -R easybuild:easybuild /home/easybuild/EasyBuild-develop.eb /home/easy
# install pep8, keyring, keyrings.alt, and GitPython
RUN pip3 install --upgrade pip && pip3 install pep8 keyring keyrings.alt GitPython
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# switch to 'easybuild' user
USER easybuild
......
......@@ -5,7 +5,7 @@ ARG IMG_TAG=7.9.2009
# allow CI/CD to change all of the above
FROM ${IMG_REGISTRY}/${IMG_ORG}/${IMG_NAME}:${IMG_TAG}
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# install required packages (EPEL is required for Lmod)
# RUN yum update -y
......
......@@ -16,7 +16,7 @@ RUN chown -R easybuild:easybuild /home/easybuild/EasyBuild-develop.eb /home/easy
# install pep8, keyring, keyrings.alt, and GitPython
RUN pip3 install --upgrade pip && pip3 install pep8 keyring keyrings.alt GitPython
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# switch to 'easybuild' user
USER easybuild
......
......@@ -5,7 +5,7 @@ ARG IMG_TAG=8.4.2105
# allow CI/CD to change all of the above
FROM ${IMG_REGISTRY}/${IMG_ORG}/${IMG_NAME}:${IMG_TAG}
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# install required packages (EPEL is required for Lmod)
# RUN yum update -y
......
......@@ -16,7 +16,7 @@ RUN chown -R easybuild:easybuild /home/easybuild/EasyBuild-develop.eb /home/easy
# install pep8, keyring, keyrings.alt, and GitPython
RUN pip3 install --upgrade pip && pip3 install pep8 keyring keyrings.alt GitPython
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# switch to 'easybuild' user
USER easybuild
......
......@@ -5,7 +5,7 @@ ARG IMG_TAG=8.5
# allow CI/CD to change all of the above
FROM ${IMG_REGISTRY}/${IMG_ORG}/${IMG_NAME}:${IMG_TAG}
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# install required packages (EPEL is required for Lmod)
# RUN yum update -y
......
......@@ -16,7 +16,7 @@ RUN chown -R easybuild:easybuild /home/easybuild/EasyBuild-develop.eb /home/easy
# install pep8, keyring, keyrings.alt, and GitPython
RUN pip3 install --upgrade pip && pip3 install pep8 keyring keyrings.alt GitPython
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# switch to 'easybuild' user
USER easybuild
......
......@@ -5,7 +5,7 @@ ARG IMG_TAG=22.04
# allow CI/CD to change all of the above
FROM ${IMG_REGISTRY}/${IMG_ORG}/${IMG_NAME}:${IMG_TAG}
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
ENV LMOD_VER 8.6
LABEL easybuild_version=${EB_VER}
# install required packages
......
......@@ -13,7 +13,7 @@ RUN chown -R easybuild:easybuild /home/easybuild/EasyBuild-develop.eb /home/easy
# install pep8, keyring, keyrings.alt, and GitPython
RUN pip3 install --upgrade pip && pip3 install pep8 keyring keyrings.alt GitPython
# set default easybuild version
ARG EB_VER=4.5.3
ARG EB_VER=4.5.4
LABEL easybuild_version=${EB_VER}
# switch to 'easybuild' user
USER easybuild
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment